Skip to content

Percona Server for MySQL 5.7.37-40 (2022-03-31)

Percona Server for MySQL 5.7.37-40 includes all the features and bug fixes available in MySQL 5.7.37 Community Edition in addition to enterprise-grade features developed by Percona.

Percona Server for MySQL is a free, fully compatible, enhanced, and open source drop-in replacement for any MySQL database. It delivers more value to MySQL server users with optimized performance, greater performance scalability and availability, enhanced backups, and increased visibility. Commercial support contracts are available.

Release Highlights

The following lists a number of the notable updates and fixes for MySQL 5.7.37, provided by Oracle, and included in Percona Server for MySQL:

  • The performance on debug builds has been improved by optimizing buf_validate() function in the InnoDB sources.

  • Fix for when a query using an index that differs from the primary key of partitioned table results in excessive CPU load.

Find the complete list of bug fixes and changes in MySQL 5.7.37 Release Notes.

Improvements

  • PS-7792: Allows setting an empty MASTER_USER user name if you always provide user credentials when using the START_SLAVE statement. This method requires user intervention to restart the replica.

Bugs Fixed

  • PS-7929: Fix for when the row locks were duplicated when inserting an existing row into a table within the same transaction.

  • PS-8007: Percona Server for MySQL can fail to start if the server starts before the network mounts the datadir or a local mount of the datadir.

  • PS-7856: A partition table update caused a server exit.

  • PS-7890: When the server was started with the –loose-rocksdb_persistent_cache_size_mb option, the RocksDB engine plugin installation failed.

Packaging Notes

  • Red Hat Enterprise Linux 6 (and derivative Linux distributions) are no longer supported.

  • Debian 9 is no longer supported.

Known issues

  • The RPM packages for Red Hat Enterprise Linux 7 (and compatible derivatives) do not support TLSv1.3, as it requires OpenSSL 1.1.1, which is currently not available on this platform.