Skip to content

Versions compatibility

Versions of the cluster components and platforms tested with different Operator releases are shown below. Other version combinations may also work but have not been tested.

Cluster components:

Operator PostgreSQL pgBackRest pgBouncer
2.3.1 12 - 16 2.48 1.18.0
2.3.0 12 - 16 2.48 1.18.0
2.2.0 12 - 15 2.43 1.18.0
2.1.0 12 - 15 2.43 1.18.0
2.0.0 12 - 14 2.41 1.17.0
1.5.1 12 - 14 2.47 1.20.0
1.5.0 12 - 14 2.47 1.20.0
1.4.0 12 - 14 2.43 1.18.0
1.3.0 12 - 14 2.38 1.17.0
1.2.0 12 - 14 2.37 1.16.1
1.1.0 12 - 14 2.34 1.16.0 for PostgreSQL 12,
1.16.1 for other versions
1.0.0 12 - 13 2.33 1.13.0

Platforms:

Operator GKE EKS Openshift Minikube
2.3.1 1.24 - 1.28 1.24 - 1.28 4.11.55 - 4.14.6 1.32
2.3.0 1.24 - 1.28 1.24 - 1.28 4.11.55 - 4.14.6 1.32
2.2.0 1.23 - 1.26 1.23 - 1.27 - 1.30.1
2.1.0 1.23 - 1.25 1.23 - 1.25 - -
2.0.0 1.22 - 1.25 - - -
1.5.1 1.24 - 1.28 1.24 - 1.28 4.11 - 4.14 1.32
1.5.0 1.24 - 1.28 1.24 - 1.28 4.11 - 4.14 1.32
1.4.0 1.22 - 1.25 1.22 - 1.25 4.10 - 4.12 1.28
1.3.0 1.21 - 1.24 1.20 - 1.22 4.7 - 4.10 -
1.2.0 1.19 - 1.22 1.19 - 1.21 4.7 - 4.10 -
1.1.0 1.19 - 1.22 1.18 - 1.21 4.7 - 4.9 -
1.0.0 1.17 - 1.21 1.21 4.6 - 4.8 -

Get expert help

If you need assistance, visit the community forum for comprehensive and free database knowledge, or contact our Percona Database Experts for professional support and services. Join K8S Squad to benefit from early access to features and “ask me anything” sessions with the Experts.


Last update: 2024-02-19