Skip to content

System Requirements

The Operator is validated for deployment on Kubernetes, GKE and EKS clusters. The Operator is cloud native and storage agnostic, working with a wide variety of storage classes, hostPath, and NFS.

Officially supported platforms

The Operator was developed and tested with PostgreSQL versions 12.18, 13.14, and 14.11. Other options may also work but have not been tested. The Operator 1.6.0 provides connection pooling based on pgBouncer 1.22.0 and high-availability implementation based on Patroni 3.2.2.

The following platforms were tested and are officially supported by the Operator 1.6.0:

Other Kubernetes platforms may also work but have not been tested.


Last update: 2024-05-23